Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 18, 2026 - 00:00 EDT
Scheduled
During this maintenance window, our engineers will be rebooting multiple Cloud Hypervisors to address hardware issues and apply system updates. This maintenance will impact a small number of clients, as hypervisors will be taken offline individually to minimize service disruption.
During each hypervisor reboot, all cloud servers hosted on the affected hypervisor will be temporarily unavailable. We expect downtime for impacted cloud servers to be approximately 30 minutes while the hypervisor is restarted and services are restored.
If you experience any issues with your cloud server after the maintenance has been completed, please contact our Help Desk at tickets@tritondatacenter.com.
We appreciate your patience and understanding as we perform these improvements to maintain the reliability and performance of our platform.
Posted Jun 17, 2026 - 18:02 EDT
This scheduled maintenance affected: Cloud Infrastructure (Cloud Servers (us-central-1)).